<!DOCTYPE html>
<html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#">
<head>
<meta charset="UTF-8">
<script type="text/javascript">
var gform;gform||(document.addEventListener("gform_main_scripts_loaded",function(){gform.scriptsLoaded=!0}),window.addEventListener("DOMContentLoaded",function(){gform.domLoaded=!0}),gform={domLoaded:!1,scriptsLoaded:!1,initializeOnLoaded:function(o){gform.domLoaded&&gform.scriptsLoaded?o():!gform.domLoaded&&gform.scriptsLoaded?window.addEventListener("DOMContentLoaded",o):document.addEventListener("gform_main_scripts_loaded",o)},hooks:{action:{},filter:{}},addAction:function(o,n,r,t){gform.addHook("action",o,n,r,t)},addFilter:function(o,n,r,t){gform.addHook("filter",o,n,r,t)},doAction:function(o){gform.doHook("action",o,arguments)},applyFilters:function(o){return gform.doHook("filter",o,arguments)},removeAction:function(o,n){gform.removeHook("action",o,n)},removeFilter:function(o,n,r){gform.removeHook("filter",o,n,r)},addHook:function(o,n,r,t,i){null==gform.hooks[o][n]&&(gform.hooks[o][n]=[]);var e=gform.hooks[o][n];null==i&&(i=n+"_"+e.length),gform.hooks[o][n].push({tag:i,callable:r,priority:t=null==t?10:t})},doHook:function(n,o,r){var t;if(r=Array.prototype.slice.call(r,1),null!=gform.hooks[n][o]&&((o=gform.hooks[n][o]).sort(function(o,n){return o.priority-n.priority}),o.forEach(function(o){"function"!=typeof(t=o.callable)&&(t=window[t]),"action"==n?t.apply(null,r):r[0]=t.apply(null,r)})),"filter"==n)return r[0]},removeHook:function(o,n,t,i){var r;null!=gform.hooks[o][n]&&(r=(r=gform.hooks[o][n]).filter(function(o,n,r){return!!(null!=i&&i!=o.tag||null!=t&&t!=o.priority)}),gform.hooks[o][n]=r)}});
</script>

<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<!-- Start Of Social Graph Protocol Meta Data -->
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:description" content="The Fox is back, and Dean Haspiel is in control. Despite being pretty strong characters, the Mighty Crusaders from Archie Comics and/or Red Circle" />
<meta property="og:title" content="The Fox Returns To Archie Comics!" />
<meta property="article:tag" content="Alex Toth" />
<meta property="article:tag" content="Archie Comics" />
<meta property="article:tag" content="Dean Haspiel" />
<meta property="article:tag" content="Jamie L. Rotante" />
<meta property="article:tag" content="Mark Waid" />
<meta property="article:tag" content="Red Circle Comics" />
<meta property="article:tag" content="Richard Ortiz" />
<meta property="article:tag" content="The Fox" />
<meta property="article:tag" content="Vito Delsante" />
<meta property="og:url" content="https://fanboyplanet.com/the-fox-returns-to-archie-comics/" />
<meta property="og:image" content="https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/The-Fox-Family-Values-banner-500x234.jpg" />
<meta property="og:site_name" content="Fanboy Planet" />
<!-- End Of Social Graph Protocol Meta Data -->

	<!-- This site is optimized with the Yoast SEO plugin v17.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>The Fox Returns To Archie Comics! - Fanboy Planet</title>
	<meta name="description" content="Archie Comics returns to superhero storytelling with Dean Haspiel picking up on masked hero and freak magnet The Fox." />
	<link rel="canonical" href="https://fanboyplanet.com/the-fox-returns-to-archie-comics/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="The Fox Returns To Archie Comics! - Fanboy Planet" />
	<meta property="og:description" content="Archie Comics returns to superhero storytelling with Dean Haspiel picking up on masked hero and freak magnet The Fox." />
	<meta property="og:url" content="https://fanboyplanet.com/the-fox-returns-to-archie-comics/" />
	<meta property="og:site_name" content="Fanboy Planet" />
	<meta property="article:published_time" content="2022-01-14T17:53:33+00:00" />
	<meta property="article:modified_time" content="2022-01-14T17:53:34+00:00" />
	<meta property="og:image" content="https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/The-Fox-Family-Values-banner.jpg" />
	<meta property="og:image:width" content="1000" />
	<meta property="og:image:height" content="467" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Derek McCaw" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="3 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://fanboyplanet.com/#website","url":"https://fanboyplanet.com/","name":"Fanboy Planet","description":"Reviews, interviews, and opinions on comics, movies, television, and wrestling.","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://fanboyplanet.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://fanboyplanet.com/the-fox-returns-to-archie-comics/#primaryimage","inLanguage":"en-US","url":"https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/The-Fox-Family-Values-banner.jpg","contentUrl":"https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/The-Fox-Family-Values-banner.jpg","width":1000,"height":467},{"@type":"WebPage","@id":"https://fanboyplanet.com/the-fox-returns-to-archie-comics/#webpage","url":"https://fanboyplanet.com/the-fox-returns-to-archie-comics/","name":"The Fox Returns To Archie Comics! - Fanboy Planet","isPartOf":{"@id":"https://fanboyplanet.com/#website"},"primaryImageOfPage":{"@id":"https://fanboyplanet.com/the-fox-returns-to-archie-comics/#primaryimage"},"datePublished":"2022-01-14T17:53:33+00:00","dateModified":"2022-01-14T17:53:34+00:00","author":{"@id":"https://fanboyplanet.com/#/schema/person/9db67962b9591d2513c1b122d60c4c3a"},"description":"Archie Comics returns to superhero storytelling with Dean Haspiel picking up on masked hero and freak magnet The Fox.","breadcrumb":{"@id":"https://fanboyplanet.com/the-fox-returns-to-archie-comics/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://fanboyplanet.com/the-fox-returns-to-archie-comics/"]}]},{"@type":"BreadcrumbList","@id":"https://fanboyplanet.com/the-fox-returns-to-archie-comics/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://fanboyplanet.com/"},{"@type":"ListItem","position":2,"name":"The Fox Returns To Archie Comics!"}]},{"@type":"Person","@id":"https://fanboyplanet.com/#/schema/person/9db67962b9591d2513c1b122d60c4c3a","name":"Derek McCaw","image":{"@type":"ImageObject","@id":"https://fanboyplanet.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/a134a66218eb924c0f0d26d8be4575e9?s=96&r=g","contentUrl":"https://secure.gravatar.com/avatar/a134a66218eb924c0f0d26d8be4575e9?s=96&r=g","caption":"Derek McCaw"},"description":"In addition to running Fanboy Planet, Derek has written for ActionAce, Daily Radar, Once Upon A Dime, and The Wave. He has contributed stories to Arcana Comics (The Greatest American Hero) and Monsterverse Comics (Bela Lugosi's Tales from the Grave). He has performed with ComedySportz and Silicon Valley Shakespeare, though relocated to Hollywood to... work in an office? If you ever played Eric's Ultimate Solitaire on the Macintosh, it was Derek's voice as The Weasel that urged you to play longer. You can buy his book \"I Was Flesh Gordon\" on the Amazon link at the right. Email him at editor@fanboyplanet.com.","sameAs":["https://fanboyplanet.com"],"url":"https://fanboyplanet.com/author/dmccaw/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//ws.sharethis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v8.3.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-5265288-2"  type="text/javascript" data-cfasync="false" data-wpfc-render="false" async></script>
			<script type="text/javascript" data-cfasync="false" data-wpfc-render="false">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</script>
				<!-- / Google Analytics by MonsterInsights -->
				<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/fanboyplanet.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.3"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<style type="text/css">.pt_splitter {
	display: block;
}</style><link rel='stylesheet' id='wgs2-css'  href='https://fanboyplanet.com/wp-content/plugins/wp-google-search/wgs2.css?ver=5.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='fb_data_style-css'  href='https://fanboyplanet.com/wp-content/plugins/feedburner-form/control/fbstyle.css?ver=5.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://fanboyplanet.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://fanboyplanet.com/wp-includes/css/dashicons.min.css?ver=5.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='aba_frontEndCSS-css'  href='https://fanboyplanet.com/wp-content/plugins/ad-blocking-advisor/css/frontend.css?ver=5.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:400,400italic,700,600' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-lite-css'  href='https://fanboyplanet.com/wp-content/themes/mh-magazine-lite/style.css?ver=2.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='https://fanboyplanet.com/wp-content/themes/mh-magazine-lite/includes/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='amazon-link-style-css'  href='https://fanboyplanet.com/wp-content/plugins/amazon-link/Amazon.css?ver=3.2.10' type='text/css' media='all' />
<link rel='stylesheet' id='gd-core-css'  href='https://fanboyplanet.com/wp-content/plugins/pws-core-3.5.3/public/css/GD-cORe-public.css?ver=3.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='pp-animate-css'  href='https://fanboyplanet.com/wp-content/plugins/bbpowerpack/assets/css/animate.min.css?ver=3.5.1' type='text/css' media='all' />
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/fanboyplanet.com","hash_tracking":"false","ua":"UA-5265288-2","v4_id":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://fanboyplanet.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend-gtag.min.js?ver=8.3.0' id='monsterinsights-frontend-script-js'></script>
<script type='text/javascript' src='https://fanboyplanet.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://fanboyplanet.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://fanboyplanet.com/wp-content/plugins/ad-blocking-advisor/js/ad-blocking-advisor.js?ver=5.8.3' id='aba_script-js'></script>
<script type='text/javascript' src='https://fanboyplanet.com/wp-content/themes/mh-magazine-lite/js/scripts.js?ver=2.9.1' id='mh-scripts-js'></script>
<script type='text/javascript' src='https://fanboyplanet.com/wp-content/plugins/pws-core-3.5.3/public/js/GD-cORe-public.js?ver=3.5.3' id='gd-core-js'></script>
<script id='st_insights_js' type='text/javascript' src='https://ws.sharethis.com/button/st_insights.js?publisher=eba0f3ba-f9ab-408c-bc68-c28af5afe749&#038;product=feather' id='feather-sharethis-js'></script>
<script type='text/javascript' src='https://fanboyplanet.com/wp-content/plugins/wp-smush-pro/app/assets/js/smush-lazy-load.min.js?ver=3.9.4' id='smush-lazy-load-js'></script>
<link rel="https://api.w.org/" href="https://fanboyplanet.com/wp-json/" /><link rel="alternate" type="application/json" href="https://fanboyplanet.com/wp-json/wp/v2/posts/43425" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://fanboyplanet.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://fanboyplanet.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.3" />
<link rel='shortlink' href='https://fanboyplanet.com/?p=43425' />
<link rel="alternate" type="application/json+oembed" href="https://fanboyplanet.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffanboyplanet.com%2Fthe-fox-returns-to-archie-comics%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://fanboyplanet.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffanboyplanet.com%2Fthe-fox-returns-to-archie-comics%2F&#038;format=xml" />
		<script>
			var bb_powerpack = {
				ajaxurl: 'https://fanboyplanet.com/wp-admin/admin-ajax.php'
			};
		</script>
		<script type="text/javascript">
  var _kmq = _kmq || [];
  function _kms(u){
    setTimeout(function(){
	var s = document.createElement('script'); var f = document.getElementsByTagName('script')[0]; s.type = 'text/javascript'; s.async = true;
    s.src = u; f.parentNode.insertBefore(s, f);
    }, 1);
  }
  _kms('//i.stage.kissmetrics.com/i.js');_kms('//scripts.stage.kissmetrics.com/327abdcea136d3b15d7b3fbb46cb0d97cb7484dd.2.js');</script>
<script type="text/javascript">
  _kmq.push(function() {
    if(document.getElementsByTagName('body')[0].className.match('home')) {
    	_kmq.push(['record', 'Viewed Blog Homepage']);
    }
  });
</script>
<script type="text/javascript"><!--
function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}
//-->
</script>
<link rel="apple-touch-icon" sizes="57x57" href="/wp-content/uploads/fbrfg/apple-touch-icon-57x57.png?v=ngg2JQbW4o">
<link rel="apple-touch-icon" sizes="60x60" href="/wp-content/uploads/fbrfg/apple-touch-icon-60x60.png?v=ngg2JQbW4o">
<link rel="apple-touch-icon" sizes="72x72" href="/wp-content/uploads/fbrfg/apple-touch-icon-72x72.png?v=ngg2JQbW4o">
<link rel="apple-touch-icon" sizes="76x76" href="/wp-content/uploads/fbrfg/apple-touch-icon-76x76.png?v=ngg2JQbW4o">
<link rel="apple-touch-icon" sizes="114x114" href="/wp-content/uploads/fbrfg/apple-touch-icon-114x114.png?v=ngg2JQbW4o">
<link rel="apple-touch-icon" sizes="120x120" href="/wp-content/uploads/fbrfg/apple-touch-icon-120x120.png?v=ngg2JQbW4o">
<link rel="apple-touch-icon" sizes="144x144" href="/wp-content/uploads/fbrfg/apple-touch-icon-144x144.png?v=ngg2JQbW4o">
<link rel="apple-touch-icon" sizes="152x152" href="/wp-content/uploads/fbrfg/apple-touch-icon-152x152.png?v=ngg2JQbW4o">
<link rel="apple-touch-icon" sizes="180x180" href="/wp-content/uploads/fbrfg/apple-touch-icon-180x180.png?v=ngg2JQbW4o">
<link rel="icon" type="image/png" href="/wp-content/uploads/fbrfg/favicon-32x32.png?v=ngg2JQbW4o" sizes="32x32">
<link rel="icon" type="image/png" href="/wp-content/uploads/fbrfg/favicon-194x194.png?v=ngg2JQbW4o" sizes="194x194">
<link rel="icon" type="image/png" href="/wp-content/uploads/fbrfg/favicon-96x96.png?v=ngg2JQbW4o" sizes="96x96">
<link rel="icon" type="image/png" href="/wp-content/uploads/fbrfg/android-chrome-192x192.png?v=ngg2JQbW4o" sizes="192x192">
<link rel="icon" type="image/png" href="/wp-content/uploads/fbrfg/favicon-16x16.png?v=ngg2JQbW4o" sizes="16x16">
<link rel="manifest" href="/wp-content/uploads/fbrfg/manifest.json?v=ngg2JQbW4o">
<link rel="shortcut icon" href="/wp-content/uploads/fbrfg/favicon.ico?v=ngg2JQbW4o">
<meta name="apple-mobile-web-app-title" content="Fanboy Planet">
<meta name="application-name" content="Fanboy Planet">
<meta name="msapplication-TileColor" content="#2d89ef">
<meta name="msapplication-TileImage" content="/wp-content/uploads/fbrfg/mstile-144x144.png?v=ngg2JQbW4o">
<meta name="msapplication-config" content="/wp-content/uploads/fbrfg/browserconfig.xml?v=ngg2JQbW4o">
<meta name="theme-color" content="#ffffff">		<script>
			document.documentElement.className = document.documentElement.className.replace( 'no-js', 'js' );
		</script>
		<!--[if lt IE 9]>
<script src="https://fanboyplanet.com/wp-content/themes/mh-magazine-lite/js/css3-mediaqueries.js"></script>
<![endif]-->

<style type="text/css" xmlns="http://www.w3.org/1999/html">

/*
PowerPress subscribe sidebar widget
*/
.widget-area .widget_powerpress_subscribe h2,
.widget-area .widget_powerpress_subscribe h3,
.widget-area .widget_powerpress_subscribe h4,
.widget_powerpress_subscribe h2,
.widget_powerpress_subscribe h3,
.widget_powerpress_subscribe h4 {
	margin-bottom: 0;
	padding-bottom: 0;
}
</style>

<style type="text/css"></style>

<style type="text/css">
.synved-social-resolution-single {
display: inline-block;
}
.synved-social-resolution-normal {
display: inline-block;
}
.synved-social-resolution-hidef {
display: none;
}

@media only screen and (min--moz-device-pixel-ratio: 2),
only screen and (-o-min-device-pixel-ratio: 2/1),
only screen and (-webkit-min-device-pixel-ratio: 2),
only screen and (min-device-pixel-ratio: 2),
only screen and (min-resolution: 2dppx),
only screen and (min-resolution: 192dpi) {
	.synved-social-resolution-normal {
	display: none;
	}
	.synved-social-resolution-hidef {
	display: inline-block;
	}
}
</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #000066; }
</style>
	</head>
<body id="mh-mobile" class="post-template-default single single-post postid-43425 single-format-standard custom-background mh-right-sb" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="mh-container mh-container-outer">
<div class="mh-header-mobile-nav mh-clearfix"></div>
<header class="mh-header" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
	<div class="mh-container mh-container-inner mh-row mh-clearfix">
		<div class="mh-custom-header mh-clearfix">
<a class="mh-header-image-link" href="https://fanboyplanet.com/" title="Fanboy Planet" rel="home">
<img   height="220" width="1080" alt="Fanboy Planet" data-src="https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/FBPBanner20210327.png" class="mh-header-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="mh-header-image" src="https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/FBPBanner20210327.png" height="220" width="1080" alt="Fanboy Planet" /></noscript>
</a>
</div>
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-navigation mh-main-nav mh-container mh-container-inner mh-clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
			<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-23" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-23"><a href="https://fanboyplanet.com/category/comics/">Comics</a></li>
<li id="menu-item-26" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26"><a href="https://fanboyplanet.com/category/movies/">Movies</a></li>
<li id="menu-item-24" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24"><a href="https://fanboyplanet.com/category/tv/">TV</a></li>
<li id="menu-item-27" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27"><a href="https://fanboyplanet.com/category/podcast/">Podcast</a></li>
<li id="menu-item-25" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25"><a href="https://fanboyplanet.com/category/grab-bag/">Grab Bag</a></li>
</ul></div>		</nav>
	</div>
</header><div class="mh-wrapper mh-clearfix">
	<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><article id="post-43425" class="post-43425 post type-post status-publish format-standard has-post-thumbnail hentry category-comics tag-alex-toth tag-archie-comics tag-dean-haspiel tag-jamie-l-rotante tag-mark-waid tag-red-circle-comics tag-richard-ortiz tag-the-fox tag-vito-delsante">
	<header class="entry-header mh-clearfix"><h1 class="entry-title">The Fox Returns To Archie Comics!</h1><p class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://fanboyplanet.com/2022/01/">January 14, 2022</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://fanboyplanet.com/author/dmccaw/">Derek McCaw</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://fanboyplanet.com/category/comics/" rel="category tag">Comics</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a class="mh-comment-scroll" href="https://fanboyplanet.com/the-fox-returns-to-archie-comics/#mh-comments">0</a></span>
</p>
	</header>
		<div class="entry-content mh-clearfix">
<figure class="entry-thumbnail">
<img  alt="" title="The Fox Family Values banner" data-src="https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/The-Fox-Family-Values-banner-678x381.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/The-Fox-Family-Values-banner-678x381.jpg" alt="" title="The Fox Family Values banner" /></noscript>
</figure>
<p>The Fox is back, and Dean Haspiel is in control. Despite being pretty strong characters, the Mighty Crusaders from Archie Comics and/or Red Circle have trouble catching reader&#8217;s attentions. Maybe it&#8217;s because on the surface they look like knock-offs of other more popular characters. (The average comics reader doesn&#8217;t know or care that The Shield predates Captain America.)</p>
<p>So you have to do something different. A few years ago, Archie Comics did, bringing Mark Waid and Dean Haspiel to put a twist on The Fox. The result was an energetic, loopy superhero book that was like nothing else out there at the time. An investigative journalist can&#8217;t help but attract trouble &#8212; quite literally. The problem &#8212; and luckily, superpowers &#8212; spreads to his wife and son, and <em>The Fox: Freak Magnet</em> was fun as heck.</p>
<p>Admittedly, making The Fox a &#8220;freak magnet&#8221; echoed Blue Devil living in the House of Weirdness, but it was 100% its own thing. After a couple of mini-series, like almost everything Archie except for the core Archie characters, The Fox faded away until the next attempt.</p>
<p>Now he&#8217;s back in a one-shot special, guided by the architect of what made him so strong. Dean Haspiel returns to continue and expand the story, aided by Vito Delsante and Richard Ortiz, with colorist Matt Herms and letterer Jack Morelli. <em>The Fox: Family Values </em>covers several eras &#8212; including reprinting a 1960s Fox story by Alex Toth.</p>
<p><a href="https://fanboyplanet.com/the-fox-returns-to-archie-comics/the-fox-family-values-one-shot_main/" rel="attachment wp-att-43432"><img  src="https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/The-Fox-Family-Values-One-Shot_Main-324x500.jpg" alt="" width="324" height="500" srcset="https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/The-Fox-Family-Values-One-Shot_Main-324x500.jpg 324w, https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/The-Fox-Family-Values-One-Shot_Main-519x800.jpg 519w, https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/The-Fox-Family-Values-One-Shot_Main-665x1024.jpg 665w, https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/The-Fox-Family-Values-One-Shot_Main-768x1183.jpg 768w, https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/The-Fox-Family-Values-One-Shot_Main-997x1536.jpg 997w, https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/The-Fox-Family-Values-One-Shot_Main.jpg 701w" sizes="(max-width: 324px) 100vw, 324px" class="aligncenter size-thumbnail wp-image-43432 no-lazyload" /></a></p>
<p>&#8220;What&#8217;s so interesting about this character is that he&#8217;s a superhero unlike any other—he can deftly tackle both serious issues and weird and wacky villains and situations all in the same issue,&#8221; said Senior Director of Editorial Jamie L. Rotante. The 60s version had hints of that, too. With his previous series, Haspiel expanded the Fox family, and they&#8217;re all here: The Fox, She-Fox, and their son Ghost Fox.&#8221;</p>
<p>On his lead story &#8220;Mid-Life Pisces&#8221; Haspiel commented, “When I plotted and drew ten issues of <em>The Fox</em>, I was basically given full latitude to do what I wanted and it encouraged me to open all kinds of unexpected doors. After a good 5-year break, I wondered where The Fox was these days and realized his ‘freak magnet’ curse had become a family affair. I decided to explore a day-in-the-life story about a man and his wife and their son and how each one of them deals with their idea of what it means to be a hero. I also wanted to deliver a tale that could introduce The Fox to new readers and spark the possibility of more stories!”</p>
<div id='gallery-1' class='gallery galleryid-43425 gallery-columns-3 gallery-size-thumbnail'><figure class='gallery-item'>
			<div class='gallery-icon portrait'>
				<a href='https://fanboyplanet.com/the-fox-returns-to-archie-comics/fox-2022-cover-ideas-1/'><img width="368" height="500" src="https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/FOX-2022-cover-ideas-1-368x500.jpg"  alt="" srcset="https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/FOX-2022-cover-ideas-1-368x500.jpg 368w, https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/FOX-2022-cover-ideas-1-588x800.jpg 588w, https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/FOX-2022-cover-ideas-1.jpg 741w" sizes="(max-width: 368px) 100vw, 368px" class="attachment-thumbnail size-thumbnail no-lazyload" /></a>
			</div></figure><figure class='gallery-item'>
			<div class='gallery-icon portrait'>
				<a href='https://fanboyplanet.com/the-fox-returns-to-archie-comics/fox-mid-life-pisces-inks-01/'><img width="340" height="500" src="https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/FOX-Mid-Life-Pisces-inks-01-340x500.jpg"  alt="" srcset="https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/FOX-Mid-Life-Pisces-inks-01-340x500.jpg 340w, https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/FOX-Mid-Life-Pisces-inks-01-545x800.jpg 545w, https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/FOX-Mid-Life-Pisces-inks-01-697x1024.jpg 697w, https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/FOX-Mid-Life-Pisces-inks-01.jpg 714w" sizes="(max-width: 340px) 100vw, 340px" class="attachment-thumbnail size-thumbnail no-lazyload" /></a>
			</div></figure><figure class='gallery-item'>
			<div class='gallery-icon portrait'>
				<a href='https://fanboyplanet.com/the-fox-returns-to-archie-comics/fox-mid-life-pisces-inks-05/'><img width="350" height="500" src="https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/FOX-Mid-Life-Pisces-inks-05-350x500.jpg"  alt="" srcset="https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/FOX-Mid-Life-Pisces-inks-05-350x500.jpg 350w, https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/FOX-Mid-Life-Pisces-inks-05-560x800.jpg 560w, https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/FOX-Mid-Life-Pisces-inks-05.jpg 705w" sizes="(max-width: 350px) 100vw, 350px" class="attachment-thumbnail size-thumbnail no-lazyload" /></a>
			</div></figure>
		</div>

<p>Delsante and Ortiz contribute a story set before the Foxes got married. It seems that magnetism kicked in before they even realized it.</p>
<p><em>The Fox: Family Values</em> hits your local comics shop on May 18, 2022. Hopefully, this will lead to more. Archie Comics does Archie well, but you really should see that they do more genres well.</p>
<p><a href="https://fanboyplanet.com/the-fox-returns-to-archie-comics/the-fox-family-values-one-shot_caltsoudas_variant_v3/" rel="attachment wp-att-43431"><img  src="https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/The-Fox-Family-Values-One-Shot_Caltsoudas_Variant_v3-324x500.jpg" alt="" width="324" height="500" srcset="https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/The-Fox-Family-Values-One-Shot_Caltsoudas_Variant_v3-324x500.jpg 324w, https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/The-Fox-Family-Values-One-Shot_Caltsoudas_Variant_v3-519x800.jpg 519w, https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/The-Fox-Family-Values-One-Shot_Caltsoudas_Variant_v3-665x1024.jpg 665w, https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/The-Fox-Family-Values-One-Shot_Caltsoudas_Variant_v3-768x1183.jpg 768w, https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/The-Fox-Family-Values-One-Shot_Caltsoudas_Variant_v3-997x1536.jpg 997w, https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/The-Fox-Family-Values-One-Shot_Caltsoudas_Variant_v3.jpg 701w" sizes="(max-width: 324px) 100vw, 324px" class="aligncenter size-thumbnail wp-image-43431 no-lazyload" /></a></p>
<p><a rel="nofollow" target="_blank" href="http://www.amazon.com/gp/product/1936975939?ie=UTF8&amp;linkCode=xm2&amp;camp=2025&amp;creative=6738&amp;tag=fanbplan-20&amp;creativeASIN=1936975939&amp;SubscriptionId=AKIAJJFGT27GY2EODW6A">Pick up the first mini-series by Mark Waid and Dean Haspiel here!</a></p>
<p><em>Fanboy Planet is affiliated with some vendors listed on this site, including Amazon. Any purchases made through links on this page or site may result in revenue for us.</em></p>
<a class="synved-social-button synved-social-button-share synved-social-size-48 synved-social-resolution-single synved-social-provider-facebook nolightbox" data-provider="facebook" target="_blank" rel="nofollow" title="Share on Facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Ffanboyplanet.com%2F%3Fp%3D43425&#038;t=The%20Fox%20Returns%20To%20Archie%20Comics%21&#038;s=100&#038;p&#091;url&#093;=https%3A%2F%2Ffanboyplanet.com%2F%3Fp%3D43425&#038;p&#091;images&#093;&#091;0&#093;=https%3A%2F%2Ffanboy-planet.s3.us-west-1.amazonaws.com%2Fwp-content%2Fuploads%2FThe-Fox-Family-Values-banner.jpg&#038;p&#091;title&#093;=The%20Fox%20Returns%20To%20Archie%20Comics%21" style="font-size: 0px; width:48px;height:48px;margin:0;margin-bottom:5px;margin-right:5px;"><img alt="Facebook" title="Share on Facebook"  width="48" height="48" style="display: inline; width:48px;height:48px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://fanboyplanet.com/wp-content/plugins/social-media-feather/synved-social/image/social/regular/96x96/facebook.png" class="synved-share-image synved-social-image synved-social-image-share no-lazyload" /></a><a class="synved-social-button synved-social-button-share synved-social-size-48 synved-social-resolution-single synved-social-provider-twitter nolightbox" data-provider="twitter" target="_blank" rel="nofollow" title="Share on Twitter" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Ffanboyplanet.com%2F%3Fp%3D43425&#038;text=Hey%20check%20this%20out" style="font-size: 0px; width:48px;height:48px;margin:0;margin-bottom:5px;"><img alt="twitter" title="Share on Twitter"  width="48" height="48" style="display: inline; width:48px;height:48px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://fanboyplanet.com/wp-content/plugins/social-media-feather/synved-social/image/social/regular/96x96/twitter.png" class="synved-share-image synved-social-image synved-social-image-share no-lazyload" /></a>	</div><div class="entry-tags mh-clearfix"><i class="fa fa-tag"></i><ul><li><a href="https://fanboyplanet.com/tag/alex-toth/" rel="tag">Alex Toth</a></li><li><a href="https://fanboyplanet.com/tag/archie-comics/" rel="tag">Archie Comics</a></li><li><a href="https://fanboyplanet.com/tag/dean-haspiel/" rel="tag">Dean Haspiel</a></li><li><a href="https://fanboyplanet.com/tag/jamie-l-rotante/" rel="tag">Jamie L. Rotante</a></li><li><a href="https://fanboyplanet.com/tag/mark-waid/" rel="tag">Mark Waid</a></li><li><a href="https://fanboyplanet.com/tag/red-circle-comics/" rel="tag">Red Circle Comics</a></li><li><a href="https://fanboyplanet.com/tag/richard-ortiz/" rel="tag">Richard Ortiz</a></li><li><a href="https://fanboyplanet.com/tag/the-fox/" rel="tag">The Fox</a></li><li><a href="https://fanboyplanet.com/tag/vito-delsante/" rel="tag">Vito Delsante</a></li></ul></div></article><div class="mh-author-box mh-clearfix">
	<figure class="mh-author-box-avatar">
		<img alt='' src='https://secure.gravatar.com/avatar/a134a66218eb924c0f0d26d8be4575e9?s=90&#038;r=g' srcset='https://secure.gravatar.com/avatar/a134a66218eb924c0f0d26d8be4575e9?s=180&#038;r=g 2x'  height='90' width='90' class='avatar avatar-90 photo no-lazyload' />	</figure>
	<div class="mh-author-box-header">
		<span class="mh-author-box-name">
			About Derek McCaw		</span>
					<span class="mh-author-box-postcount">
				<a href="https://fanboyplanet.com/author/dmccaw/" title="More articles written by Derek McCaw'">
					2061 Articles				</a>
			</span>
			</div>
			<div class="mh-author-box-bio">
			In addition to running Fanboy Planet, Derek has written for ActionAce, Daily Radar, Once Upon A Dime, and The Wave. He has contributed stories to Arcana Comics (The Greatest American Hero) and Monsterverse Comics (Bela Lugosi's Tales from the Grave). He has performed with ComedySportz and Silicon Valley Shakespeare, though relocated to Hollywood to... work in an office? If you ever played Eric's Ultimate Solitaire on the Macintosh, it was Derek's voice as The Weasel that urged you to play longer. You can buy his book "I Was Flesh Gordon" on the Amazon link at the right. Email him at editor@fanboyplanet.com.		</div>
	</div><nav class="mh-post-nav mh-row mh-clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://fanboyplanet.com/lockdown-rewind-bloodshot/" rel="prev"><img width="80" height="60" src="https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/Lockdown-Rewind-Bloodshot-80x60.png"  alt="" srcset="https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/Lockdown-Rewind-Bloodshot-80x60.png 80w, https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/Lockdown-Rewind-Bloodshot-678x509.png 678w, https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/Lockdown-Rewind-Bloodshot-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-lite-small size-mh-magazine-lite-small wp-post-image no-lazyload" /><span>Previous</span><p>Lockdown Rewind: Bloodshot</p></a></div>
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-next">
<a href="https://fanboyplanet.com/will-this-make-you-want-to-watch-peacemaker-on-hbo-max/" rel="next"><img width="80" height="60" src="https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/peacemaker-opening-credits-80x60.png"  alt="" srcset="https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/peacemaker-opening-credits-80x60.png 80w, https://fanboy-planet.s3.us-west-1.amazonaws.com/wp-content/uploads/peacemaker-opening-credits-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-lite-small size-mh-magazine-lite-small wp-post-image no-lazyload" /><span>Next</span><p>Will THIS Make You Want To Watch Peacemaker On HBO Max?</p></a></div>
</nav>

<div id="disqus_thread"></div>
	</div>
	<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="https://schema.org/WPSideBar"><div id="search-4" class="mh-widget widget_search"><form role="search" method="get" class="search-form" action="https://fanboyplanet.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></div><div id="text-2" class="mh-widget widget_text"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Recommended</span></h4>			<div class="textwidget"><p><script src="https://bookshop.org/widgets.js" data-type="book_button" data-affiliate-id="22322" data-sku="9781476672861"></script></p>
<form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"><input name="hosted_button_id" type="hidden" value="QRHFKJK5TKCCS" /></p>
<table>
<tbody>
<tr>
<td><input name="on0" type="hidden" value="Yes, I'd like to contribute to help Fanboy Planet!" />Yes, I&#8217;d like to contribute to help Fanboy Planet!</td>
</tr>
<tr>
<td><select name="os0"><option value="$5">$5</option><option value="$10">$10</option><option value="$25">$25</option><option value="$35">$35</option></select></td>
</tr>
</tbody>
</table>
<p><input alt="PayPal - The safer, easier way to pay online!" name="submit" src="https://www.paypalobjects.com/en_US/i/btn/btn_subscribeCC_LG.gif" type="image" /></p>
<p><iframe id="$iradid" src="//a.impactradius-go.com/gen-ad-code/377176/1181029/3065/" frameborder="0" marginwidth="0" marginheight="0" scrolling="no" class="no-lazyload"></iframe><br />
<iframe style="border: none;" src="//rcm-na.amazon-adsystem.com/e/cm?o=1&amp;p=12&amp;l=ur1&amp;category=audibleplus&amp;banner=0MG2XKQ7PYPP84NBNFR2&amp;f=ifr&amp;lc=pf4&amp;linkID=dd435f74b6cdb9cd4b2dd3bc0f4ade68&amp;t=fanbplan-20&amp;tracking_id=fanbplan-20" frameborder="0" marginwidth="0" scrolling="no" class="no-lazyload"></iframe></p>
<p>&nbsp;</p>
<div id="amzn-assoc-ad-14b02091-c488-4d60-bcea-2a34066c0e1d"></div>
<p><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&#038;adInstanceId=14b02091-c488-4d60-bcea-2a34066c0e1d"></script></p>
<p><ins class="adsbygoogle" style="display: inline-block; width: 300px; height: 250px;" data-ad-slot="8525360330" data-ad-client="ca-pub-4823774997893316"></ins><script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script><br />
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-4823774997893316",
          enable_page_level_ads: true
     });
</script></p>
</form>
</div>
		</div>

    <div id="feedburnerformwidget-2" class="mh-widget widget_feedburnerformwidget">
    <!-- Plugin Feedburner Form-->
    <div class="fb-container">
        <h4 class="mh-widget-title"><span class="mh-widget-title-inner">Subscribe</span></h4>        <div class="fbf-text">
                Enter your email address to subscribe to this blog and receive notifications of new posts by email.
<br/>
<br/>        </div>
        <form  class="fbf-widget" action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=FanboyPlanet', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true">
        <input class="subscription_email" type="text" name="email" placeholder="Email Address" /><input type="hidden" value="FanboyPlanet" name="uri"/>
        <input type="hidden" name="loc" value="en_US"/>
        <input class="subscription_btn" type="submit" value ="Go!"/>
        </form>

    
    
    </div>
    <!-- Plugin Feedburner Form-->
		</div>
    <div id="pages-5" class="mh-widget widget_pages"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Pages</span></h4>
			<ul>
				<li class="page_item page-item-2"><a href="https://fanboyplanet.com/about/">About Us</a></li>
<li class="page_item page-item-40571"><a href="https://fanboyplanet.com/privacy-policy/">Privacy Policy</a></li>
<li class="page_item page-item-42658"><a href="https://fanboyplanet.com/search_gcse/">Search Results</a></li>
<li class="page_item page-item-33"><a href="https://fanboyplanet.com/sites/">Sites We Like</a></li>
<li class="page_item page-item-35"><a href="https://fanboyplanet.com/support/">Support Us</a></li>
			</ul>

			</div><div id="synved_social_follow-5" class="mh-widget widget_synved_social_follow"><div><a class="synved-social-button synved-social-button-follow synved-social-size-64 synved-social-resolution-single synved-social-provider-facebook nolightbox" data-provider="facebook" target="_blank" rel="nofollow" title="Follow us on Facebook" href="http://www.facebook.com/FanboyPlanet" style="font-size: 0px; width:64px;height:64px;margin:0;margin-bottom:5px;margin-right:5px;"><img alt="Facebook" title="Follow us on Facebook"  width="64" height="64" style="display: inline; width:64px;height:64px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://fanboyplanet.com/wp-content/plugins/social-media-feather/synved-social/image/social/regular/128x128/facebook.png" class="synved-share-image synved-social-image synved-social-image-follow no-lazyload" /></a><a class="synved-social-button synved-social-button-follow synved-social-size-64 synved-social-resolution-single synved-social-provider-twitter nolightbox" data-provider="twitter" target="_blank" rel="nofollow" title="Follow us on Twitter" href="http://twitter.com/fanboyplanet" style="font-size: 0px; width:64px;height:64px;margin:0;margin-bottom:5px;"><img alt="twitter" title="Follow us on Twitter"  width="64" height="64" style="display: inline; width:64px;height:64px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://fanboyplanet.com/wp-content/plugins/social-media-feather/synved-social/image/social/regular/128x128/twitter.png" class="synved-share-image synved-social-image synved-social-image-follow no-lazyload" /></a></div></div></aside></div>
<footer class="mh-footer" itemscope="itemscope" itemtype="https://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row mh-clearfix">
<div class="mh-col-1-3 mh-widget-col-1 mh-footer-3-cols  mh-footer-area mh-footer-1">
<div id="categories-4" class="mh-footer-widget widget_categories"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Categories</span></h6>
			<ul>
					<li class="cat-item cat-item-50"><a href="https://fanboyplanet.com/category/books/">Books</a>
</li>
	<li class="cat-item cat-item-4"><a href="https://fanboyplanet.com/category/comics/">Comics</a>
</li>
	<li class="cat-item cat-item-256"><a href="https://fanboyplanet.com/category/games/">Games</a>
</li>
	<li class="cat-item cat-item-1"><a href="https://fanboyplanet.com/category/grab-bag/">Grab Bag</a>
</li>
	<li class="cat-item cat-item-24"><a href="https://fanboyplanet.com/category/interviews/">Interviews</a>
</li>
	<li class="cat-item cat-item-3"><a href="https://fanboyplanet.com/category/movies/">Movies</a>
</li>
	<li class="cat-item cat-item-5"><a href="https://fanboyplanet.com/category/podcast/" title="The Fanboy Planet Podcast. Broadcasting weekly. Right here.">Podcast</a>
</li>
	<li class="cat-item cat-item-29"><a href="https://fanboyplanet.com/category/reviews/">Reviews</a>
</li>
	<li class="cat-item cat-item-79"><a href="https://fanboyplanet.com/category/theme-parks/">Theme Parks</a>
</li>
	<li class="cat-item cat-item-21"><a href="https://fanboyplanet.com/category/toys/">Toys</a>
</li>
	<li class="cat-item cat-item-2"><a href="https://fanboyplanet.com/category/tv/">TV</a>
</li>
			</ul>

			</div></div>
<div class="mh-col-1-3 mh-widget-col-1 mh-footer-3-cols  mh-footer-area mh-footer-2">

		<div id="recent-posts-6" class="mh-footer-widget widget_recent_entries">
		<h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Recent Posts</span></h6>
		<ul>
											<li>
					<a href="https://fanboyplanet.com/will-this-make-you-want-to-watch-peacemaker-on-hbo-max/">Will THIS Make You Want To Watch Peacemaker On HBO Max?</a>
									</li>
											<li>
					<a href="https://fanboyplanet.com/the-fox-returns-to-archie-comics/" aria-current="page">The Fox Returns To Archie Comics!</a>
									</li>
											<li>
					<a href="https://fanboyplanet.com/lockdown-rewind-bloodshot/">Lockdown Rewind: Bloodshot</a>
									</li>
											<li>
					<a href="https://fanboyplanet.com/fanboy-planet-podcast-kolchak-the-night-stalker-at-50/">Fanboy Planet Podcast: Kolchak: The Night Stalker At 50!</a>
									</li>
											<li>
					<a href="https://fanboyplanet.com/foo-fighters-fight-demons/">Foo Fighters Fight Demons, Not Foo</a>
									</li>
					</ul>

		</div></div>
<div class="mh-col-1-3 mh-widget-col-1 mh-footer-3-cols  mh-footer-area mh-footer-3">
<div id="powerpress_subscribe-4" class="mh-footer-widget widget_powerpress_subscribe"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Subscribe to Podcast</span></h6><div class="pp-ssb-widget pp-ssb-widget-modern pp-ssb-widget-include"><a href="https://itunes.apple.com/us/podcast/fanboy-planet-podcast-series/id164051160?mt=2&#038;ls=1" class="pp-ssb-btn-sq vertical pp-ssb-itunes" title="Subscribe on Apple Podcasts"><span class="pp-ssb-ic"></span><span class="pp-ssb-text">Apple Podcasts</span></a><a href="https://www.google.com/podcasts?feed=aHR0cHM6Ly9mYW5ib3lwbGFuZXQuY29tL2ZlZWQvcG9kY2FzdC8" class="pp-ssb-btn-sq vertical  pp-ssb-gp" title="Subscribe on Google Podcasts"><span class="pp-ssb-ic"></span><span class="pp-ssb-text">Google Podcasts</span></a><a href="https://subscribeonandroid.com/fanboyplanet.com/feed/podcast/" class="pp-ssb-btn-sq  vertical pp-ssb-android" title="Subscribe on Android"><span class="pp-ssb-ic"></span><span class="pp-ssb-text">Android</span></a><a href="https://subscribebyemail.com/fanboyplanet.com/feed/podcast/" class="pp-ssb-btn-sq  vertical  pp-ssb-email" title="Subscribe by Email"><span class="pp-ssb-ic"></span><span class="pp-ssb-text">by Email</span></a><a href="https://fanboyplanet.com/feed/podcast/" class="pp-ssb-btn-sq vertical pp-ssb-rss" title="Subscribe via RSS"><span class="pp-ssb-ic"></span><span class="pp-ssb-text">RSS</span></a></div></div></div>
</div>
</footer>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner mh-clearfix">
		<p class="mh-copyright">Copyright &copy; 2022 | WordPress Theme by <a href="https://mhthemes.com/" rel="nofollow">MH Themes</a></p>
	</div>
</div>
</div><!-- .mh-container-outer -->

				<!-- Special Message (ABA) Begin -->
				<style>
					.special-message-wrapper {
						background:#C44;
						color:#FFF;
						font-size:15px;
					}
				</style>
				
				<div class="special-message-wrapper" style="display:none;">
					<div class="special-message-content">
						<div class="special-message-left">
							Please support this website by adding us to your whitelist in your ad blocker. Ads are what helps us bring you premium content! Thank you!
						</div>
						<div class="special-message-right">

			
							<span class="dashicons dashicons-no"></span>
							
						</div>
						<div style="clear:both;"></div>
					</div>
				</div>
				
				<script type="text/javascript">

					jQuery( window ).load( function() {
						if ( ! document.getElementById( "aba_detector" ) ) {
							var aba_cookie = readCookie( "Ad_Blocking_Advisor_WP_Plugin" )
							if ( ! aba_cookie ) {
								jQuery( ".special-message-wrapper" ).show().prependTo( jQuery( "body" ) );
							}
						}
					});
					
					jQuery( ".special-message-right" ).click(function(){
						// User clicked close.
						jQuery( ".special-message-wrapper" ).hide();
			
						createCookie( "Ad_Blocking_Advisor_WP_Plugin", "closed", 2 );
					
					});
				</script>
				<!-- Special Message (ABA) End -->
			<link rel='stylesheet' id='powerpress_subscribe_widget_modern-css'  href='https://fanboyplanet.com/wp-content/plugins/powerpress/css/subscribe-widget.min.css?ver=8.7.9' type='text/css' media='all' />
<script type='text/javascript' id='google_cse_v2-js-extra'>
/* <![CDATA[ */
var scriptParams = {"google_search_engine_id":"002035833672648265384:7ptkagkj77g"};
/* ]]> */
</script>
<script type='text/javascript' src='https://fanboyplanet.com/wp-content/plugins/wp-google-search/assets/js/google_cse_v2.js?ver=1' id='google_cse_v2-js'></script>
<script type='text/javascript' src='https://fanboyplanet.com/wp-content/plugins/ad-blocking-advisor/js/ads.js?ver=1642372091' id='aba_detector-js'></script>
<script type='text/javascript' id='disqus_count-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"fanboyplanet"};
/* ]]> */
</script>
<script type='text/javascript' src='https://fanboyplanet.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.22' id='disqus_count-js'></script>
<script type='text/javascript' id='disqus_embed-js-extra'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.22"},"disqusIdentifier":"43425 https:\/\/fanboyplanet.com\/?p=43425","disqusShortname":"fanboyplanet","disqusTitle":"The Fox Returns To Archie Comics!","disqusUrl":"https:\/\/fanboyplanet.com\/the-fox-returns-to-archie-comics\/","postId":"43425"};
/* ]]> */
</script>
<script type='text/javascript' src='https://fanboyplanet.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.22' id='disqus_embed-js'></script>
<script type='text/javascript' src='https://fanboyplanet.com/wp-includes/js/comment-reply.min.js?ver=5.8.3' id='comment-reply-js'></script>
<script type='text/javascript' src='https://fanboyplanet.com/wp-includes/js/wp-embed.min.js?ver=5.8.3' id='wp-embed-js'></script>
		<script>'undefined'=== typeof _trfq || (window._trfq = []);'undefined'=== typeof _trfd && (window._trfd=[]),_trfd.push({'tccl.baseHost':'secureserver.net'}),_trfd.push({'ap':'wpaas'},{'server':'62c2c0c3-0273-8869-339c-7f8b524ede55.secureserver.net'},{'pod':'P3NLWPPOD02'},{'storage':'p3pewpnas02pod02_data03'},{'xid':'2819293'},{'wp':'5.8.3'},{'php':'7.3.30'},{'loggedin':'0'},{'cdn':'0'},{'builder':'wp-classic-editor'},{'theme':'mh-magazine-lite'},{'nextgen':'0'},{'wds':'1'},{'wp_alloptions_count':'487'},{'wp_alloptions_bytes':'248827'})</script>
		<script>window.addEventListener('click', function (elem) { var _elem$target, _elem$target$dataset, _window, _window$_trfq; return (elem === null || elem === void 0 ? void 0 : (_elem$target = elem.target) === null || _elem$target === void 0 ? void 0 : (_elem$target$dataset = _elem$target.dataset) === null || _elem$target$dataset === void 0 ? void 0 : _elem$target$dataset.eid) && ((_window = window) === null || _window === void 0 ? void 0 : (_window$_trfq = _window._trfq) === null || _window$_trfq === void 0 ? void 0 : _window$_trfq.push(["cmdLogEvent", "click", elem.target.dataset.eid]));});</script>
		<script src='https://img1.wsimg.com/tcc/tcc_l.combined.1.0.6.min.js'></script>
		<script src='https://img1.wsimg.com/traffic-assets/js/tccl-tti.min.js' onload="window.tti.calculateTTI()"></script>
		</body>
</html>