<!DOCTYPE html>
<html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="https://fanboyplanet.com/xmlrpc.php"/>
<title>Christopher Eccleston Returns To Doctor Who &#8211; Fanboy Planet</title>

<!-- Start Of Social Graph Protocol Meta Data -->
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:description" content="Never say never.Christopher Eccleston, the actor who brought Doctor Who back to life on television and left after one series, will return to the" />
<meta property="og:title" content="Christopher Eccleston Returns To Doctor Who" />
<meta property="article:tag" content="audio" />
<meta property="article:tag" content="audio drama" />
<meta property="article:tag" content="big finish productions" />
<meta property="article:tag" content="Christopher Eccleston" />
<meta property="article:tag" content="Doctor Who" />
<meta property="article:tag" content="Gallifrey One" />
<meta property="article:tag" content="I Love the Bones of You" />
<meta property="article:tag" content="jason haigh-ellery" />
<meta property="article:tag" content="Nicholas Briggs" />
<meta property="article:tag" content="The 9th Doctor" />
<meta property="article:tag" content="Time Lord Victorious" />
<meta property="og:url" content="https://fanboyplanet.com/christopher-eccleston-returns-to-doctor-who/" />
<meta property="og:image" content="https://s3.us-east-2.amazonaws.com/fanboy.planet/wp-content/uploads/doctor-who-bingo-press-image-2-500x281.jpg" />
<meta property="og:site_name" content="Fanboy Planet" />
<!-- End Of Social Graph Protocol Meta Data -->
<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//ws.sharethis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='preconnect' href='https://secureservercdn.net' crossorigin />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.12.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.12.0';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-5265288-2';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-5265288-2', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/secureservercdn.net\/45.40.155.145\/6a0.dfd.myftpupload.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2&time=1597015698"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<style type="text/css">.pt_splitter {
	display: block;
}</style><link rel='stylesheet' id='fb_data_style-css'  href='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-content/plugins/feedburner-form/control/fbstyle.css?ver=5.4.2&#038;time=1597015698' type='text/css' media='all' />
<link rel='stylesheet' id='gsc_style-css'  href='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-content/plugins/google-custom-search/css/smoothness/jquery-ui.theme.min.css?ver=5.4.2&#038;time=1597015698' type='text/css' media='all' />
<link rel='stylesheet' id='gsc_style_search_bar-css'  href='https://www.google.com/cse/style/look/minimalist.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='gsc_style_search_bar_more-css'  href='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-content/plugins/google-custom-search/css/gsc.css?ver=5.4.2&#038;time=1597015698' type='text/css' media='all' />
<link rel='stylesheet' id='gsc_style_search_bar_even_more-css'  href='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-content/plugins/google-custom-search/css/gsc-no-search-button.css?ver=5.4.2&#038;time=1597015698' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2&#038;time=1597015698' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-includes/css/dashicons.min.css?ver=5.4.2&#038;time=1597015698' type='text/css' media='all' />
<link rel='stylesheet' id='aba_frontEndCSS-css'  href='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-content/plugins/ad-blocking-advisor/css/frontend.css?ver=5.4.2&#038;time=1597015698' type='text/css' media='all' />
<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:400,400italic,700,600' type='text/css' media='all' />
<link rel='stylesheet' id='mh-style-css'  href='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-content/themes/mh-magazine-lite/style.css?ver=1.9.3&#038;time=1597015698' type='text/css' media='all' />
<link rel='stylesheet' id='amazon-link-style-css'  href='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-content/plugins/amazon-link/Amazon.css?ver=3.2.10&#038;time=1597015698' type='text/css' media='all' />
<script type='text/javascript' src='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp&#038;time=1597015698'></script>
<script type='text/javascript' src='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1&#038;time=1597015698'></script>
<script type='text/javascript' src='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-content/plugins/google-custom-search/js/gsc.js?ver=5.4.2&#038;time=1597015698'></script>
<script type='text/javascript' src='https://www.google.com/jsapi?ver=5.4.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/fanboyplanet.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.12.0&#038;time=1597015698'></script>
<script type='text/javascript' src='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-content/plugins/ad-blocking-advisor/js/ad-blocking-advisor.js?ver=5.4.2&#038;time=1597015698'></script>
<script type='text/javascript' src='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-content/themes/mh-magazine-lite/js/scripts.js?ver=5.4.2&#038;time=1597015698'></script>
<script id='st_insights_js' type='text/javascript' src='https://ws.sharethis.com/button/st_insights.js?publisher=eba0f3ba-f9ab-408c-bc68-c28af5afe749&#038;product=feather'></script>
<link rel='https://api.w.org/' href='https://fanboyplanet.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://fanboyplanet.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-includes/wlwmanifest.xml?time=1597015698" /> 
<link rel='prev' title='Fanboy Planet Podcast Episode #581: Three on a Podcast' href='https://fanboyplanet.com/fanboy-planet-podcast-episode-581-three-on-a-podcast/' />
<meta name="generator" content="WordPress 5.4.2" />
<link rel="canonical" href="https://fanboyplanet.com/christopher-eccleston-returns-to-doctor-who/" />
<link rel='shortlink' href='https://fanboyplanet.com/?p=35940' />
<link rel="alternate" type="application/json+oembed" href="https://fanboyplanet.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffanboyplanet.com%2Fchristopher-eccleston-returns-to-doctor-who%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://fanboyplanet.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffanboyplanet.com%2Fchristopher-eccleston-returns-to-doctor-who%2F&#038;format=xml" />
<script type="text/javascript">
  var _kmq = _kmq || [];
  function _kms(u){
    setTimeout(function(){
	var s = document.createElement('script'); var f = document.getElementsByTagName('script')[0]; s.type = 'text/javascript'; s.async = true;
    s.src = u; f.parentNode.insertBefore(s, f);
    }, 1);
  }
  _kms('//i.stage.kissmetrics.com/i.js');_kms('//scripts.stage.kissmetrics.com/327abdcea136d3b15d7b3fbb46cb0d97cb7484dd.2.js');</script>
<script type="text/javascript">
  _kmq.push(function() {
    if(document.getElementsByTagName('body')[0].className.match('home')) {
    	_kmq.push(['record', 'Viewed Blog Homepage']);
    }
  });
</script>
<script type="text/javascript"><!--
function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}
//-->
</script>
<link rel="apple-touch-icon" sizes="57x57" href="/wp-content/uploads/fbrfg/apple-touch-icon-57x57.png?v=ngg2JQbW4o">
<link rel="apple-touch-icon" sizes="60x60" href="/wp-content/uploads/fbrfg/apple-touch-icon-60x60.png?v=ngg2JQbW4o">
<link rel="apple-touch-icon" sizes="72x72" href="/wp-content/uploads/fbrfg/apple-touch-icon-72x72.png?v=ngg2JQbW4o">
<link rel="apple-touch-icon" sizes="76x76" href="/wp-content/uploads/fbrfg/apple-touch-icon-76x76.png?v=ngg2JQbW4o">
<link rel="apple-touch-icon" sizes="114x114" href="/wp-content/uploads/fbrfg/apple-touch-icon-114x114.png?v=ngg2JQbW4o">
<link rel="apple-touch-icon" sizes="120x120" href="/wp-content/uploads/fbrfg/apple-touch-icon-120x120.png?v=ngg2JQbW4o">
<link rel="apple-touch-icon" sizes="144x144" href="/wp-content/uploads/fbrfg/apple-touch-icon-144x144.png?v=ngg2JQbW4o">
<link rel="apple-touch-icon" sizes="152x152" href="/wp-content/uploads/fbrfg/apple-touch-icon-152x152.png?v=ngg2JQbW4o">
<link rel="apple-touch-icon" sizes="180x180" href="/wp-content/uploads/fbrfg/apple-touch-icon-180x180.png?v=ngg2JQbW4o">
<link rel="icon" type="image/png" href="/wp-content/uploads/fbrfg/favicon-32x32.png?v=ngg2JQbW4o" sizes="32x32">
<link rel="icon" type="image/png" href="/wp-content/uploads/fbrfg/favicon-194x194.png?v=ngg2JQbW4o" sizes="194x194">
<link rel="icon" type="image/png" href="/wp-content/uploads/fbrfg/favicon-96x96.png?v=ngg2JQbW4o" sizes="96x96">
<link rel="icon" type="image/png" href="/wp-content/uploads/fbrfg/android-chrome-192x192.png?v=ngg2JQbW4o" sizes="192x192">
<link rel="icon" type="image/png" href="/wp-content/uploads/fbrfg/favicon-16x16.png?v=ngg2JQbW4o" sizes="16x16">
<link rel="manifest" href="/wp-content/uploads/fbrfg/manifest.json?v=ngg2JQbW4o">
<link rel="shortcut icon" href="/wp-content/uploads/fbrfg/favicon.ico?v=ngg2JQbW4o">
<meta name="apple-mobile-web-app-title" content="Fanboy Planet">
<meta name="application-name" content="Fanboy Planet">
<meta name="msapplication-TileColor" content="#2d89ef">
<meta name="msapplication-TileImage" content="/wp-content/uploads/fbrfg/mstile-144x144.png?v=ngg2JQbW4o">
<meta name="msapplication-config" content="/wp-content/uploads/fbrfg/browserconfig.xml?v=ngg2JQbW4o">
<meta name="theme-color" content="#ffffff"><!--[if lt IE 9]>
<script src="https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-content/themes/mh-magazine-lite/js/css3-mediaqueries.js"></script>
<![endif]-->
  <!-- Header Tag Code --><script data-cfasync='false' type='text/javascript'>/*<![CDATA[*/(function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: "2.1", q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u + new Date(Math.floor(new Date().getTime() / 6e5) * 6e5).getTime(); b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//embed.insticator.com/embeds/script?sid=123d3e0f-18bb-48fb-a6d4-778fd7ba1015&cbt=');/*]]>*/</script>  <!-- End Header Tag Code -->
<style type="text/css" xmlns="http://www.w3.org/1999/html">

/*
PowerPress subscribe sidebar widget
*/
.widget-area .widget_powerpress_subscribe h2,
.widget-area .widget_powerpress_subscribe h3,
.widget-area .widget_powerpress_subscribe h4,
.widget_powerpress_subscribe h2,
.widget_powerpress_subscribe h3,
.widget_powerpress_subscribe h4 {
	margin-bottom: 0;
	padding-bottom: 0;
}
</style>

<style type="text/css"></style>

<style type="text/css">
.synved-social-resolution-single {
display: inline-block;
}
.synved-social-resolution-normal {
display: inline-block;
}
.synved-social-resolution-hidef {
display: none;
}

@media only screen and (min--moz-device-pixel-ratio: 2),
only screen and (-o-min-device-pixel-ratio: 2/1),
only screen and (-webkit-min-device-pixel-ratio: 2),
only screen and (min-device-pixel-ratio: 2),
only screen and (min-resolution: 2dppx),
only screen and (min-resolution: 192dpi) {
	.synved-social-resolution-normal {
	display: none;
	}
	.synved-social-resolution-hidef {
	display: inline-block;
	}
}
</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #000066; }
</style>
	</head>
<body class="post-template-default single single-post postid-35940 single-format-standard custom-background mh-right-sb">
<div class="mh-container">
<header class="header-wrap">
	<div class="logo-wrap" role="banner">
<a href="https://fanboyplanet.com/" title="Fanboy Planet" rel="home"><img src="https://fanboyplanet.s3.amazonaws.com/wp-content/uploads/12033308_10156044138825153_260061385_n.jpg" height="196" width="960" alt="Fanboy Planet" /></a>
</div>
	<div class="mobile-nav"></div>
	<nav class="main-nav clearfix">
		<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-23" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23"><a href="https://fanboyplanet.com/category/comics/">Comics</a></li>
<li id="menu-item-26" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26"><a href="https://fanboyplanet.com/category/movies/">Movies</a></li>
<li id="menu-item-24" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-24"><a href="https://fanboyplanet.com/category/tv/">TV</a></li>
<li id="menu-item-27" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-27"><a href="https://fanboyplanet.com/category/podcast/">Podcast</a></li>
<li id="menu-item-25" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25"><a href="https://fanboyplanet.com/category/grab-bag/">Grab Bag</a></li>
</ul></div>	</nav>
</header><div class="mh-wrapper clearfix">
	<div id="main-content" class="mh-content"><article class="post-35940 post type-post status-publish format-standard has-post-thumbnail hentry category-podcast category-tv tag-audio tag-audio-drama tag-big-finish-productions tag-christopher-eccleston tag-doctor-who tag-gallifrey-one tag-i-love-the-bones-of-you tag-jason-haigh-ellery tag-nicholas-briggs tag-the-9th-doctor tag-time-lord-victorious">
	<header class="post-header">
		<h1 class="entry-title">Christopher Eccleston Returns To Doctor Who</h1>
		<div class="subheading-top"></div>
<h2 class="subheading">Big Finish announces several 9th Doctor adventures with the actor</h2>
		<p class="meta post-meta">Posted on <span class="updated">August 9, 2020</span> by <span class="vcard author"><span class="fn"><a href="https://fanboyplanet.com/author/dmccaw/" title="Posts by Derek McCaw" rel="author">Derek McCaw</a></span></span> in <a href="https://fanboyplanet.com/category/podcast/" rel="category tag">Podcast</a>, <a href="https://fanboyplanet.com/category/tv/" rel="category tag">TV</a>  //  <span class="dsq-postid" data-dsqidentifier="35940 https://fanboyplanet.com/?p=35940">0 Comments</span></p>
	</header>
		<div class="entry clearfix">
		
<div class="post-thumbnail">
<img src="https://s3.us-east-2.amazonaws.com/fanboy.planet/wp-content/uploads/doctor-who-bingo-press-image-2-620x349.jpg" alt="" title="doctor-who-bingo-press-image-2" />
</div>
		<p>Never say never.</p>
<p>Christopher Eccleston, the actor who brought Doctor Who back to life on television and left after one series, will return to the role for a series of adventures for Big Finish Audio &#8212; beginning in May 2021 with the first of four boxed sets of three episodes each.</p>
<p>Honestly, I keep checking the date to make sure we didn&#8217;t all travel to an endless April 1, but <a href="https://www.bbcstudios.com/news/christopher-eccleston-returns-to-doctor-who/?fbclid=IwAR3jHQM5Ozvd5FxkDHTmCxyXWySIQe7jH6PcglsdxdnHuDn03LRlTlIHVAo" target="_blank" rel="noopener noreferrer">BBC Studios reports that it&#8217;s true</a>. Though in the past couple of years Eccleston had softened and come to embrace his fandom, his exit from the series had been contentious. As recently as Gallifrey One in February, he had expressed that while he appreciated everyone wanting him back, he didn&#8217;t want to revisit the role. However, on the Big Finish site, they&#8217;ve included a quote from Eccleston:<em> “After 15 years it will be exciting to revisit the Ninth Doctor&#8217;s world, bringing back to life a character I love playing.” </em></p>
<p>But let&#8217;s turn to that Gallifrey One, his first appearance there, where he was met with overwhelming affection. (I&#8217;m not exaggerating there.) The last day of the convention was his birthday, and when he stepped out on stage, the entire audience spontaneously stood and sang Happy Birthday to him. He thanked everyone for the love. Maybe fandom got to him. Or maybe it was Big Finish co-founder and chairman Jason Haigh-Ellery.</p>
<blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/B8piucYhThL/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:620px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);">
<div style="padding:16px;"> <a href="https://www.instagram.com/p/B8piucYhThL/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"> </p>
<div style=" display: flex; flex-direction: row; align-items: center;">
<div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;">
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div>
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div>
</div>
</div>
<div style="padding: 19% 0;"></div>
<div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div>
<div style="padding-top: 8px;">
<div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div>
</div>
<div style="padding: 12.5% 0;"></div>
<div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;">
<div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div>
<div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div>
</div>
<div style="margin-left: 8px;">
<div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div>
<div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div>
</div>
<div style="margin-left: auto;">
<div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div>
<div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div>
<div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div>
</div>
</div>
<p></a> </p>
<p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/B8piucYhThL/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">The audience sings #happy birthday to @christophereccleston at Sunday morning’s panel at #gally1. Take that love back with you, sir, and again, thank you for being here.</a></p>
<p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/fanboyplanet/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> Derek McCaw</a> (@fanboyplanet) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2020-02-17T01:13:51+00:00">Feb 16, 2020 at 5:13pm PST</time></p>
</div>
</blockquote>
<p><script async src="//www.instagram.com/embed.js"></script></p>
<p>In the BBC article, Haigh-Ellery comments, &#8220;<em>I first talked to Christopher about returning to the role of the Doctor at a fan convention in February this year. Christopher said he was enjoying meeting the fans and was pleased that his Doctor was remembered so fondly. I am so pleased that Christopher has decided to return to the role with us – and I&#8217;m excited to welcome him to the Big Finish family as we discover the new adventures of the Ninth Doctor.”</em></p>
<blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/B8pACG4hXUm/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:620px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);">
<div style="padding:16px;"> <a href="https://www.instagram.com/p/B8pACG4hXUm/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"> </p>
<div style=" display: flex; flex-direction: row; align-items: center;">
<div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;">
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div>
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div>
</div>
</div>
<div style="padding: 19% 0;"></div>
<div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div>
<div style="padding-top: 8px;">
<div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div>
</div>
<div style="padding: 12.5% 0;"></div>
<div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;">
<div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div>
<div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div>
</div>
<div style="margin-left: 8px;">
<div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div>
<div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div>
</div>
<div style="margin-left: auto;">
<div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div>
<div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div>
<div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div>
</div>
</div>
<p></a> </p>
<p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/B8pACG4hXUm/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">Happy Birthday to @christophereccleston &#8211; thank you for spending it with us at @gallifreyone! #gally1 #christophereccleston #doctorwho #theleftovers #anactorslife</a></p>
<p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/fanboyplanet/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> Derek McCaw</a> (@fanboyplanet) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2020-02-16T20:09:03+00:00">Feb 16, 2020 at 12:09pm PST</time></p>
</div>
</blockquote>
<p><script async src="//www.instagram.com/embed.js"></script></p>
<p>And that was <em>after</em> a Big Finish panel in which Haigh-Ellery had admitted that Eccleston had been cool to the idea when fans asked.  <strong>UPDATE: Gallifrey One agrees with us.</strong></p>
<blockquote class="twitter-tweet">
<p dir="ltr" lang="en">We think the moment Chris Eccleston changed his mind at <a href="https://twitter.com/hashtag/gally1?src=hash&amp;ref_src=twsrc%5Etfw">#gally1</a> 2020 was taking the stage Sunday morning and being hit with the entire room singing Happy Birthday to him. To our attendees: thanks. To the rest of the fan world, you&#8217;re welcome. 🙂</p>
<p>— Gallifrey One (@gallifreyone) <a href="https://twitter.com/gallifreyone/status/1292519515448700928?ref_src=twsrc%5Etfw">August 9, 2020</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>Let&#8217;s be honest &#8212; what Big Finish has been able to do with the &#8220;New Who&#8221; has been high quality, especially when the original actors agree to return. John Hurt and Derek Jacobi both reprised their roles as &#8220;The War Doctor&#8221; and &#8220;The War Master,&#8221; respectively, in two separate series of adventures. Recently, <a href="https://fanboyplanet.com/taking-it-easy-with-torchwood-tropical-beach-sounds-and-other-relaxing-seascapes-4/">Sir Michael Palin performed a <em>Torchwood </em>adventure</a>. And David Tennant will be teaming with Tom Baker for an audio series, as well as with Paul McGann for part of the <em>Time Lord Victorious </em>event.</p>
<p>It also helped that Big Finish Creative Director Nicholas Briggs began his association with the Doctor by voicing the Dalek in the Eccleston episode &#8220;Dalek.&#8221; Briggs enthused, <em>“Working with Chris was a very special time for me. The beginning of my Doctor Who TV career. So, writing for and directing him feels incredibly exciting. He’s such a powerful performer and it’ll be amazing to work with him again.”</em></p>
<p>On stage and in his recent memoir, <a rel="nofollow" target="_blank" href="http://www.amazon.com/gp/product/1471176312?ie=UTF8&amp;linkCode=xm2&amp;camp=2025&amp;creative=6738&amp;tag=fanbplan-20&amp;creativeASIN=1471176312&amp;SubscriptionId=AKIAJJFGT27GY2EODW6A"><em>I Love the Bones of You</em></a>, Eccleston has emphasized that he focuses on quality work and that starts with quality writing. Clearly, he&#8217;s found both with Big Finish. <a href="https://www.bigfinish.com/news/v/christopher-eccleston-returns-to-doctor-who" target="_blank" rel="noopener noreferrer">Pre-orders are available now</a>.</p>
<p><em>Fanboy Planet has no affiliation with Big Finish Productions, other than as fans. We are affiliated with Amazon, and any purchases made through Amazon links on this site may generate revenue for Fanboy Planet.</em></p>
<a class="synved-social-button synved-social-button-share synved-social-size-48 synved-social-resolution-single synved-social-provider-facebook nolightbox" data-provider="facebook" target="_blank" rel="nofollow" title="Share on Facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Ffanboyplanet.com%2Fchristopher-eccleston-returns-to-doctor-who%2F&#038;t=Christopher%20Eccleston%20Returns%20To%20Doctor%20Who&#038;s=100&#038;p&#091;url&#093;=https%3A%2F%2Ffanboyplanet.com%2Fchristopher-eccleston-returns-to-doctor-who%2F&#038;p&#091;images&#093;&#091;0&#093;=https%3A%2F%2Fs3.us-east-2.amazonaws.com%2Ffanboy.planet%2Fwp-content%2Fuploads%2Fdoctor-who-bingo-press-image-2.jpg&#038;p&#091;title&#093;=Christopher%20Eccleston%20Returns%20To%20Doctor%20Who" style="font-size: 0px; width:48px;height:48px;margin:0;margin-bottom:5px;margin-right:5px;"><img alt="Facebook" title="Share on Facebook" class="synved-share-image synved-social-image synved-social-image-share" width="48" height="48" style="display: inline; width:48px;height:48px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-content/plugins/social-media-feather/synved-social/image/social/regular/96x96/facebook.png" /></a><a class="synved-social-button synved-social-button-share synved-social-size-48 synved-social-resolution-single synved-social-provider-twitter nolightbox" data-provider="twitter" target="_blank" rel="nofollow" title="Share on Twitter" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Ffanboyplanet.com%2Fchristopher-eccleston-returns-to-doctor-who%2F&#038;text=Hey%20check%20this%20out" style="font-size: 0px; width:48px;height:48px;margin:0;margin-bottom:5px;"><img alt="twitter" title="Share on Twitter" class="synved-share-image synved-social-image synved-social-image-share" width="48" height="48" style="display: inline; width:48px;height:48px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-content/plugins/social-media-feather/synved-social/image/social/regular/96x96/twitter.png" /></a>	</div>
			<div class="post-tags clearfix">
        	<ul><li><a href="https://fanboyplanet.com/tag/audio/" rel="tag">audio</a></li><li><a href="https://fanboyplanet.com/tag/audio-drama/" rel="tag">audio drama</a></li><li><a href="https://fanboyplanet.com/tag/big-finish-productions/" rel="tag">big finish productions</a></li><li><a href="https://fanboyplanet.com/tag/christopher-eccleston/" rel="tag">Christopher Eccleston</a></li><li><a href="https://fanboyplanet.com/tag/doctor-who/" rel="tag">Doctor Who</a></li><li><a href="https://fanboyplanet.com/tag/gallifrey-one/" rel="tag">Gallifrey One</a></li><li><a href="https://fanboyplanet.com/tag/i-love-the-bones-of-you/" rel="tag">I Love the Bones of You</a></li><li><a href="https://fanboyplanet.com/tag/jason-haigh-ellery/" rel="tag">jason haigh-ellery</a></li><li><a href="https://fanboyplanet.com/tag/nicholas-briggs/" rel="tag">Nicholas Briggs</a></li><li><a href="https://fanboyplanet.com/tag/the-9th-doctor/" rel="tag">The 9th Doctor</a></li><li><a href="https://fanboyplanet.com/tag/time-lord-victorious/" rel="tag">Time Lord Victorious</a></li></ul>        </div>
		</article><section class="author-box">
<div class="author-box-wrap clearfix">
<div class="author-box-avatar"><img alt='' src='https://secure.gravatar.com/avatar/a134a66218eb924c0f0d26d8be4575e9?s=113&#038;r=g' srcset='https://secure.gravatar.com/avatar/a134a66218eb924c0f0d26d8be4575e9?s=226&#038;r=g 2x' class='avatar avatar-113 photo' height='113' width='113' /></div>
<h5 class="author-box-name">About Derek McCaw</h5>
<div class="author-box-desc">In addition to running Fanboy Planet, Derek has written for ActionAce, Daily Radar, Once Upon A Dime, and The Wave. He has contributed stories to Arcana Comics (The Greatest American Hero) and Monsterverse Comics (Bela Lugosi's Tales from the Grave). He performs with ComedySportz San Jose and ShakesBEERience, in addition to occasional screenwriting and acting jobs. If you ever played Eric's Ultimate Solitaire on the Macintosh, it was Derek's voice as The Weasel that urged you to play longer. You can buy his book "I Was Flesh Gordon" on the Amazon link at the right. Email him at editor@fanboyplanet.com.</div>
</div>
</section>

<div id="disqus_thread"></div>
	</div>
	<aside class="mh-sidebar">
	<div id="text-2" class="sb-widget widget_text"><h4 class="widget-title">Recommended</h4>			<div class="textwidget"><p><iframe style="width:100%; height: 240px;" src="//ws-na.amazon-adsystem.com/widgets/q?ServiceVersion=20070822&amp;OneJS=1&amp;Operation=GetAdHtml&amp;MarketPlace=US&amp;source=ac&amp;ref=qf_sp_asin_til&amp;ad_type=product_link&amp;tracking_id=fanbplan-20&amp;marketplace=amazon&amp;region=US&amp;placement=1476672865&amp;asins=1476672865&amp;linkId=d8f6619f17c0ac2e9588cf67fd338a43&amp;show_border=false&amp;link_opens_in_new_window=false&amp;price_color=333333&amp;title_color=0066C0&amp;bg_color=FFFFFF" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"><br />
</iframe></p>
<form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"><input name="hosted_button_id" type="hidden" value="QRHFKJK5TKCCS" /></p>
<table>
<tbody>
<tr>
<td><input name="on0" type="hidden" value="Yes, I'd like to contribute to help Fanboy Planet!" />Yes, I&#8217;d like to contribute to help Fanboy Planet!</td>
</tr>
<tr>
<td><select name="os0"><option value="$5">$5</option><option value="$10">$10</option><option value="$25">$25</option><option value="$35">$35</option></select></td>
</tr>
</tbody>
</table>
<p><input alt="PayPal - The safer, easier way to pay online!" name="submit" src="https://www.paypalobjects.com/en_US/i/btn/btn_subscribeCC_LG.gif" type="image" /></p>
<p><a href="https://cbsallaccess.qflm.net/c/377176/868334/3065" id="868334"><img src="//a.impactradius-go.com/display-ad/3065-868334" border="0" alt="" width="320" height="480"/></a><img height="0" width="0" src="//cbsallaccess.qflm.net/i/377176/868334/3065" style="position:absolute;visibility:hidden;" border="0" /></p>
<p><a href="http://www.earth2comics.com/"><img class="alignnone" src="https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-content/uploads/2015/09/earth2ad.jpg" /></a></p>
<p><a href="http://www.illusivecomics.com" rel="attachment wp-att-18117"><img class="alignleft wp-image-18117 size-full" src="https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-content/uploads/2019/05/Illusive-Comics-Ad.png" alt="" width="300" height="270" /></a></p>
<div id="amzn-assoc-ad-14b02091-c488-4d60-bcea-2a34066c0e1d"></div>
<p><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&#038;adInstanceId=14b02091-c488-4d60-bcea-2a34066c0e1d"></script><br />
<!-- FanboyPlanet --><br />
<ins class="adsbygoogle" style="display: inline-block; width: 300px; height: 250px;" data-ad-slot="8525360330" data-ad-client="ca-pub-4823774997893316"></ins><br />
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script><br />
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-4823774997893316",
          enable_page_level_ads: true
     });
</script></p>
</form>
</div>
		</div>

    <div id="feedburnerformwidget-2" class="sb-widget widget_feedburnerformwidget">
    <!-- Plugin Feedburner Form-->
    <div class="fb-container">
        <h4 class="widget-title">Subscribe</h4>        <div class="fbf-text">
                Enter your email address to subscribe to this blog and receive notifications of new posts by email.
<br/>
<br/>        </div>
        <form  class="fbf-widget" action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=FanboyPlanet', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true">
        <input class="subscription_email" type="text" name="email" placeholder="Email Address" /><input type="hidden" value="FanboyPlanet" name="uri"/>
        <input type="hidden" name="loc" value="en_US"/>
        <input class="subscription_btn" type="submit" value ="Go!"/>
        </form>

    
    
    </div>
    <!-- Plugin Feedburner Form-->
		</div>
    <div id="gsc-widget-3" class="sb-widget google custom search">    <div id="cse-search-form26" style="width: 100%;">Loading</div>
    <script type="text/javascript">
        google.load('search', '1', {language: 'en_US'});
        google.setOnLoadCallback(function () {
            var customSearchControl = new google.search.CustomSearchControl('002035833672648265384:7ptkagkj77g');
            customSearchControl.setResultSetSize(google.search.Search.FILTERED_CSE_RESULTSET);
                        var options = new google.search.DrawOptions();
            options.setSearchFormRoot('cse-search-form26');
            options.setAutoComplete(true);
                        customSearchControl.draw('gcs-widget', options);
                    }, true);

        // establish a keep callback
        function CallBackDisplayDialog(result) {
            jQuery('#dialog').dialog('open');
        }
    </script>
    <div id="gcs-widget" style="width:100%;"></div></div></aside></div>
<footer class="mh-footer row clearfix">
		<div class="col-1-4 mq-footer">
		<div id="pages-5" class="footer-widget footer-1 widget_pages"><h6 class="footer-widget-title">Pages</h6>		<ul>
			<li class="page_item page-item-2"><a href="https://fanboyplanet.com/about/">About Us</a></li>
<li class="page_item page-item-33"><a href="https://fanboyplanet.com/sites/">Sites We Like</a></li>
<li class="page_item page-item-35"><a href="https://fanboyplanet.com/support/">Support Us</a></li>
		</ul>
			</div><div id="synved_social_follow-5" class="footer-widget footer-1 widget_synved_social_follow"><div><a class="synved-social-button synved-social-button-follow synved-social-size-64 synved-social-resolution-single synved-social-provider-facebook nolightbox" data-provider="facebook" target="_blank" rel="nofollow" title="Follow us on Facebook" href="http://www.facebook.com/FanboyPlanet" style="font-size: 0px; width:64px;height:64px;margin:0;margin-bottom:5px;margin-right:5px;"><img alt="Facebook" title="Follow us on Facebook" class="synved-share-image synved-social-image synved-social-image-follow" width="64" height="64" style="display: inline; width:64px;height:64px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-content/plugins/social-media-feather/synved-social/image/social/regular/128x128/facebook.png" /></a><a class="synved-social-button synved-social-button-follow synved-social-size-64 synved-social-resolution-single synved-social-provider-twitter nolightbox" data-provider="twitter" target="_blank" rel="nofollow" title="Follow us on Twitter" href="http://twitter.com/fanboyplanet" style="font-size: 0px; width:64px;height:64px;margin:0;margin-bottom:5px;"><img alt="twitter" title="Follow us on Twitter" class="synved-share-image synved-social-image synved-social-image-follow" width="64" height="64" style="display: inline; width:64px;height:64px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-content/plugins/social-media-feather/synved-social/image/social/regular/128x128/twitter.png" /></a></div></div>	</div>
			<div class="col-1-4 mq-footer">
		<div id="categories-4" class="footer-widget footer-2 widget_categories"><h6 class="footer-widget-title">Categories</h6>		<ul>
				<li class="cat-item cat-item-50"><a href="https://fanboyplanet.com/category/books/">Books</a>
</li>
	<li class="cat-item cat-item-4"><a href="https://fanboyplanet.com/category/comics/">Comics</a>
</li>
	<li class="cat-item cat-item-256"><a href="https://fanboyplanet.com/category/games/">Games</a>
</li>
	<li class="cat-item cat-item-1"><a href="https://fanboyplanet.com/category/grab-bag/">Grab Bag</a>
</li>
	<li class="cat-item cat-item-24"><a href="https://fanboyplanet.com/category/interviews/">Interviews</a>
</li>
	<li class="cat-item cat-item-3"><a href="https://fanboyplanet.com/category/movies/">Movies</a>
</li>
	<li class="cat-item cat-item-5"><a href="https://fanboyplanet.com/category/podcast/" title="The Fanboy Planet Podcast. Broadcasting weekly. Right here.">Podcast</a>
</li>
	<li class="cat-item cat-item-29"><a href="https://fanboyplanet.com/category/reviews/">Reviews</a>
</li>
	<li class="cat-item cat-item-79"><a href="https://fanboyplanet.com/category/theme-parks/">Theme Parks</a>
</li>
	<li class="cat-item cat-item-21"><a href="https://fanboyplanet.com/category/toys/">Toys</a>
</li>
	<li class="cat-item cat-item-2"><a href="https://fanboyplanet.com/category/tv/">TV</a>
</li>
		</ul>
			</div>	</div>
			<div class="col-1-4 mq-footer">
				<div id="recent-posts-6" class="footer-widget footer-3 widget_recent_entries">		<h6 class="footer-widget-title">Recent Posts</h6>		<ul>
											<li>
					<a href="https://fanboyplanet.com/christopher-eccleston-returns-to-doctor-who/" aria-current="page">Christopher Eccleston Returns To Doctor Who</a>
									</li>
											<li>
					<a href="https://fanboyplanet.com/fanboy-planet-podcast-episode-581-three-on-a-podcast/">Fanboy Planet Podcast Episode #581: Three on a Podcast</a>
									</li>
											<li>
					<a href="https://fanboyplanet.com/before-superworld-there-were-the-defenders-of-stan/">Before Superworld, There Were The Defenders Of Stan</a>
									</li>
											<li>
					<a href="https://fanboyplanet.com/flashback-friday-the-lost-watchmen-spin-off/">Flashback Friday: The Lost Watchmen Spin-off</a>
									</li>
											<li>
					<a href="https://fanboyplanet.com/boom-adapts-slaughterhouse-five/">BOOM! Adapts Slaughterhouse-Five</a>
									</li>
					</ul>
		</div>	</div>
			<div class="col-1-4 mq-footer">
		<div id="powerpress_subscribe-4" class="footer-widget footer-4 widget_powerpress_subscribe"><h6 class="footer-widget-title">Subscribe to Podcast</h6><div class="pp-ssb-widget pp-ssb-widget-modern pp-ssb-widget-include"><a href="https://itunes.apple.com/us/podcast/fanboy-planet-podcast-series/id164051160?mt=2&#038;ls=1" class="pp-ssb-btn-sq vertical pp-ssb-itunes" title="Subscribe on Apple Podcasts"><span class="pp-ssb-ic"></span><span class="pp-ssb-text">Apple Podcasts</span></a><a href="https://www.google.com/podcasts?feed=aHR0cHM6Ly9mYW5ib3lwbGFuZXQuY29tL2ZlZWQvcG9kY2FzdC8" class="pp-ssb-btn-sq vertical  pp-ssb-gp" title="Subscribe on Google Podcasts"><span class="pp-ssb-ic"></span><span class="pp-ssb-text">Google Podcasts</span></a><a href="https://subscribeonandroid.com/fanboyplanet.com/feed/podcast/" class="pp-ssb-btn-sq  vertical pp-ssb-android" title="Subscribe on Android"><span class="pp-ssb-ic"></span><span class="pp-ssb-text">Android</span></a><a href="https://subscribebyemail.com/fanboyplanet.com/feed/podcast/" class="pp-ssb-btn-sq  vertical  pp-ssb-email" title="Subscribe by Email"><span class="pp-ssb-ic"></span><span class="pp-ssb-text">by Email</span></a><a href="https://fanboyplanet.com/feed/podcast/" class="pp-ssb-btn-sq vertical pp-ssb-rss" title="Subscribe via RSS"><span class="pp-ssb-ic"></span><span class="pp-ssb-text">RSS</span></a></div></div>	</div>
	</footer>
<div class="copyright-wrap">
	<p class="copyright">Copyright &copy; 2020 | WordPress Theme by <a href="http://www.mhthemes.com/" rel="nofollow">MH Themes</a></p>
</div>
</div>

				<!-- Special Message (ABA) Begin -->
				<style>
					.special-message-wrapper {
						background:#C44;
						color:#FFF;
						font-size:15px;
					}
				</style>
				
				<div class="special-message-wrapper" style="display:none;">
					<div class="special-message-content">
						<div class="special-message-left">
							Please support this website by adding us to your whitelist in your ad blocker. Ads are what helps us bring you premium content! Thank you!
						</div>
						<div class="special-message-right">

			
							<span class="dashicons dashicons-no"></span>
							
						</div>
						<div style="clear:both;"></div>
					</div>
				</div>
				
				<script type="text/javascript">

					jQuery( window ).load( function() {
						if ( ! document.getElementById( "aba_detector" ) ) {
							var aba_cookie = readCookie( "Ad_Blocking_Advisor_WP_Plugin" )
							if ( ! aba_cookie ) {
								jQuery( ".special-message-wrapper" ).show().prependTo( jQuery( "body" ) );
							}
						}
					});
					
					jQuery( ".special-message-right" ).click(function(){
						// User clicked close.
						jQuery( ".special-message-wrapper" ).hide();
			
						createCookie( "Ad_Blocking_Advisor_WP_Plugin", "closed", 2 );
					
					});
				</script>
				<!-- Special Message (ABA) End -->
			<link rel='stylesheet' id='powerpress_subscribe_widget_modern-css'  href='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-content/plugins/powerpress/css/subscribe-widget.min.css?ver=5.4.2&#038;time=1597015698' type='text/css' media='all' />
<script type='text/javascript' src='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4&#038;time=1597015698'></script>
<script type='text/javascript' src='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4&#038;time=1597015698'></script>
<script type='text/javascript' src='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4&#038;time=1597015698'></script>
<script type='text/javascript' src='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-includes/js/jquery/ui/resizable.min.js?ver=1.11.4&#038;time=1597015698'></script>
<script type='text/javascript' src='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4&#038;time=1597015698'></script>
<script type='text/javascript' src='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-includes/js/jquery/ui/button.min.js?ver=1.11.4&#038;time=1597015698'></script>
<script type='text/javascript' src='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4&#038;time=1597015698'></script>
<script type='text/javascript' src='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-includes/js/jquery/ui/dialog.min.js?ver=1.11.4&#038;time=1597015698'></script>
<script type='text/javascript' src='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-content/plugins/ad-blocking-advisor/js/ads.js?ver=1597027554&#038;time=1597015698'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"fanboyplanet"};
/* ]]> */
</script>
<script type='text/javascript' src='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17&#038;time=1597015698'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"35940 https:\/\/fanboyplanet.com\/?p=35940","disqusShortname":"fanboyplanet","disqusTitle":"Christopher Eccleston Returns To Doctor Who","disqusUrl":"https:\/\/fanboyplanet.com\/christopher-eccleston-returns-to-doctor-who\/","postId":"35940"};
/* ]]> */
</script>
<script type='text/javascript' src='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17&#038;time=1597015698'></script>
<script type='text/javascript' src='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-includes/js/comment-reply.min.js?ver=5.4.2&#038;time=1597015698'></script>
<script type='text/javascript' src='https://secureservercdn.net/45.40.155.145/6a0.dfd.myftpupload.com/wp-includes/js/wp-embed.min.js?ver=5.4.2&#038;time=1597015698'></script>
</body>
</html>